summaryrefslogtreecommitdiff
path: root/vendor/cc/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/cc/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/cc/Cargo.toml')
-rw-r--r--vendor/cc/Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/vendor/cc/Cargo.toml b/vendor/cc/Cargo.toml
new file mode 100644
index 0000000..e597edc
--- /dev/null
+++ b/vendor/cc/Cargo.toml
@@ -0,0 +1,43 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "cc"
+version = "1.0.83"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+exclude = ["/.github"]
+description = """
+A build-time dependency for Cargo build scripts to assist in invoking the native
+C compiler to compile native C code into a static archive to be linked into Rust
+code.
+"""
+homepage = "https://github.com/rust-lang/cc-rs"
+documentation = "https://docs.rs/cc"
+readme = "README.md"
+keywords = ["build-dependencies"]
+categories = ["development-tools::build-utils"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/cc-rs"
+
+[dependencies.jobserver]
+version = "0.1.16"
+optional = true
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+parallel = ["jobserver"]
+
+[target."cfg(unix)".dependencies.libc]
+version = "0.2.62"
+default-features = false