aboutsummaryrefslogtreecommitdiff
path: root/vendor/flume/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/flume/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/flume/Cargo.toml')
-rw-r--r--vendor/flume/Cargo.toml110
1 files changed, 0 insertions, 110 deletions
diff --git a/vendor/flume/Cargo.toml b/vendor/flume/Cargo.toml
deleted file mode 100644
index 4b4eca4..0000000
--- a/vendor/flume/Cargo.toml
+++ /dev/null
@@ -1,110 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "flume"
-version = "0.11.0"
-authors = ["Joshua Barretto <joshua.s.barretto@gmail.com>"]
-exclude = [
- "/.github",
- "/misc",
-]
-description = "A blazingly fast multi-producer channel"
-documentation = "https://docs.rs/flume"
-readme = "README.md"
-keywords = [
- "mpsc",
- "fifo",
- "channel",
- "thread",
- "mpmc",
-]
-categories = [
- "concurrency",
- "data-structures",
-]
-license = "Apache-2.0/MIT"
-repository = "https://github.com/zesterer/flume"
-
-[[bench]]
-name = "basic"
-harness = false
-
-[dependencies.futures-core]
-version = "0.3"
-optional = true
-default_features = false
-
-[dependencies.futures-sink]
-version = "0.3"
-optional = true
-default_features = false
-
-[dependencies.nanorand]
-version = "0.7"
-features = ["getrandom"]
-optional = true
-
-[dependencies.spin1]
-version = "0.9.8"
-features = ["mutex"]
-package = "spin"
-
-[dev-dependencies.async-std]
-version = "1.9.0"
-features = [
- "attributes",
- "unstable",
-]
-
-[dev-dependencies.criterion]
-version = "0.3.4"
-
-[dev-dependencies.crossbeam-channel]
-version = "0.5.5"
-
-[dev-dependencies.crossbeam-utils]
-version = "0.8.10"
-
-[dev-dependencies.futures]
-version = "^0.3"
-features = ["std"]
-
-[dev-dependencies.rand]
-version = "0.8.3"
-
-[dev-dependencies.tokio]
-version = "^1.16.1"
-features = [
- "rt",
- "macros",
-]
-
-[dev-dependencies.waker-fn]
-version = "1.1.0"
-
-[features]
-async = [
- "futures-sink",
- "futures-core",
-]
-default = [
- "async",
- "select",
- "eventual-fairness",
-]
-eventual-fairness = [
- "select",
- "nanorand",
-]
-select = []
-spin = []