summaryrefslogtreecommitdiff
path: root/vendor/is-terminal/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/is-terminal/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/is-terminal/Cargo.toml')
-rw-r--r--vendor/is-terminal/Cargo.toml67
1 files changed, 67 insertions, 0 deletions
diff --git a/vendor/is-terminal/Cargo.toml b/vendor/is-terminal/Cargo.toml
new file mode 100644
index 0000000..a1168f2
--- /dev/null
+++ b/vendor/is-terminal/Cargo.toml
@@ -0,0 +1,67 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63"
+name = "is-terminal"
+version = "0.4.10"
+authors = [
+ "softprops <d.tangren@gmail.com>",
+ "Dan Gohman <dev@sunfishcode.online>",
+]
+include = [
+ "src",
+ "build.rs",
+ "Cargo.toml",
+ "COPYRIGHT",
+ "LICENSE*",
+ "/*.md",
+]
+description = "Test whether a given stream is a terminal"
+documentation = "https://docs.rs/is-terminal"
+readme = "README.md"
+keywords = [
+ "terminal",
+ "tty",
+ "isatty",
+]
+categories = ["command-line-interface"]
+license = "MIT"
+repository = "https://github.com/sunfishcode/is-terminal"
+
+[dev-dependencies.atty]
+version = "0.2.14"
+
+[target."cfg(any(unix, target_os = \"wasi\"))".dev-dependencies.libc]
+version = "0.2.110"
+
+[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dependencies.rustix]
+version = "0.38.0"
+features = ["termios"]
+
+[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dev-dependencies.rustix]
+version = "0.38.0"
+features = ["stdio"]
+
+[target."cfg(target_os = \"hermit\")".dependencies.hermit-abi]
+version = "0.3.0"
+
+[target."cfg(windows)".dependencies.windows-sys]
+version = "0.52.0"
+features = [
+ "Win32_Foundation",
+ "Win32_Storage_FileSystem",
+ "Win32_System_Console",
+]
+
+[target."cfg(windows)".dev-dependencies.tempfile]
+version = "3"