summaryrefslogtreecommitdiff
path: root/vendor/rand/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/rand/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/rand/Cargo.toml')
-rw-r--r--vendor/rand/Cargo.toml45
1 files changed, 45 insertions, 0 deletions
diff --git a/vendor/rand/Cargo.toml b/vendor/rand/Cargo.toml
new file mode 100644
index 0000000..64d240c
--- /dev/null
+++ b/vendor/rand/Cargo.toml
@@ -0,0 +1,45 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "rand"
+version = "0.4.6"
+authors = ["The Rust Project Developers"]
+description = "Random number generators and other randomness functionality.\n"
+homepage = "https://github.com/rust-lang-nursery/rand"
+documentation = "https://docs.rs/rand"
+readme = "README.md"
+keywords = ["random", "rng"]
+categories = ["algorithms"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-lang-nursery/rand"
+
+[features]
+alloc = []
+default = ["std"]
+i128_support = []
+nightly = ["i128_support"]
+std = ["libc"]
+[target."cfg(target_env = \"sgx\")".dependencies.rand_core]
+version = "0.3"
+default-features = false
+
+[target."cfg(target_env = \"sgx\")".dependencies.rdrand]
+version = "0.4.0"
+[target."cfg(target_os = \"fuchsia\")".dependencies.fuchsia-cprng]
+version = "0.1.0"
+[target."cfg(unix)".dependencies.libc]
+version = "0.2"
+optional = true
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["minwindef", "ntsecapi", "profileapi", "winnt"]