summaryrefslogtreecommitdiff
path: root/vendor/terminal_size/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/terminal_size/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/terminal_size/Cargo.toml')
-rw-r--r--vendor/terminal_size/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/vendor/terminal_size/Cargo.toml b/vendor/terminal_size/Cargo.toml
new file mode 100644
index 0000000..d892187
--- /dev/null
+++ b/vendor/terminal_size/Cargo.toml
@@ -0,0 +1,27 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "terminal_size"
+version = "0.1.17"
+authors = ["Andrew Chin <achin@eminence32.net>"]
+description = "Gets the size of your Linux or Windows terminal"
+documentation = "http://eminence.github.io/terminal-size/doc/terminal_size/index.html"
+keywords = ["terminal", "console", "term", "size", "dimensions"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/eminence/terminal-size"
+[target."cfg(not(windows))".dependencies.libc]
+version = "0.2"
+[target."cfg(windows)".dependencies.winapi]
+version = "0.3"
+features = ["handleapi", "processenv", "winbase", "wincon", "winnt"]