summaryrefslogtreecommitdiff
path: root/vendor/tiff/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/tiff/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/tiff/Cargo.toml')
-rw-r--r--vendor/tiff/Cargo.toml48
1 files changed, 48 insertions, 0 deletions
diff --git a/vendor/tiff/Cargo.toml b/vendor/tiff/Cargo.toml
new file mode 100644
index 0000000..7d7ed50
--- /dev/null
+++ b/vendor/tiff/Cargo.toml
@@ -0,0 +1,48 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.61.0"
+name = "tiff"
+version = "0.9.0"
+authors = ["The image-rs Developers"]
+exclude = [
+ "tests/images/*",
+ "tests/fuzz_images/*",
+]
+description = "TIFF decoding and encoding library in pure Rust"
+readme = "README.md"
+categories = [
+ "multimedia::images",
+ "multimedia::encoding",
+]
+license = "MIT"
+repository = "https://github.com/image-rs/image-tiff"
+resolver = "2"
+
+[[bench]]
+name = "lzw"
+harness = false
+
+[dependencies.flate2]
+version = "1.0.20"
+
+[dependencies.jpeg]
+version = "0.3.0"
+default-features = false
+package = "jpeg-decoder"
+
+[dependencies.weezl]
+version = "0.1.0"
+
+[dev-dependencies.criterion]
+version = "0.3.1"