summaryrefslogtreecommitdiff
path: root/nres-cli/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'nres-cli/Cargo.toml')
-rw-r--r--nres-cli/Cargo.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/nres-cli/Cargo.toml b/nres-cli/Cargo.toml
new file mode 100644
index 0000000..e3b1932
--- /dev/null
+++ b/nres-cli/Cargo.toml
@@ -0,0 +1,20 @@
+[package]
+name = "nres-cli"
+version = "0.2.3"
+description = "Console tool for NRes files"
+authors = ["Valentin Popov <valentin@popov.link>"]
+homepage = "https://git.popov.link/valentineus/fparkan"
+repository = "https://git.popov.link/valentineus/fparkan.git"
+license = "GPL-2.0"
+edition = "2021"
+keywords = ["cli", "gamedev", "nres"]
+
+[dependencies]
+byteorder = "1.4"
+clap = { version = "4.2", features = ["derive"] }
+console = "0.15"
+dialoguer = { version = "0.10", features = ["completion"] }
+indicatif = "0.17"
+libnres = { version = "0.1", path = "../libnres" }
+miette = { version = "5.6", features = ["fancy"] }
+tempdir = "0.3"