summaryrefslogtreecommitdiff
path: root/vendor/dialoguer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/dialoguer/Cargo.toml')
-rw-r--r--vendor/dialoguer/Cargo.toml83
1 files changed, 83 insertions, 0 deletions
diff --git a/vendor/dialoguer/Cargo.toml b/vendor/dialoguer/Cargo.toml
new file mode 100644
index 0000000..9c50fe5
--- /dev/null
+++ b/vendor/dialoguer/Cargo.toml
@@ -0,0 +1,83 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "dialoguer"
+version = "0.10.4"
+authors = [
+ "Armin Ronacher <armin.ronacher@active-4.com>",
+ "Pavan Kumar Sunkara <pavan.sss1991@gmail.com>",
+]
+description = "A command line prompting library."
+homepage = "https://github.com/mitsuhiko/dialoguer"
+documentation = "https://docs.rs/dialoguer"
+readme = "README.md"
+keywords = [
+ "cli",
+ "menu",
+ "prompt",
+]
+categories = ["command-line-interface"]
+license = "MIT"
+repository = "https://github.com/mitsuhiko/dialoguer"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[[example]]
+name = "password"
+required-features = ["password"]
+
+[[example]]
+name = "editor"
+required-features = ["editor"]
+
+[[example]]
+name = "fuzzyselect"
+required-features = ["fuzzy-select"]
+
+[[example]]
+name = "history"
+required-features = ["history"]
+
+[[example]]
+name = "completion"
+required-features = ["completion"]
+
+[dependencies.console]
+version = "0.15.0"
+
+[dependencies.fuzzy-matcher]
+version = "0.3.7"
+optional = true
+
+[dependencies.shell-words]
+version = "1.1.0"
+
+[dependencies.tempfile]
+version = "3"
+optional = true
+
+[dependencies.zeroize]
+version = "1.1.1"
+optional = true
+
+[features]
+completion = []
+default = [
+ "editor",
+ "password",
+]
+editor = ["tempfile"]
+fuzzy-select = ["fuzzy-matcher"]
+history = []
+password = ["zeroize"]