aboutsummaryrefslogtreecommitdiff
path: root/vendor/gif/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/gif/Cargo.toml')
-rw-r--r--vendor/gif/Cargo.toml83
1 files changed, 0 insertions, 83 deletions
diff --git a/vendor/gif/Cargo.toml b/vendor/gif/Cargo.toml
deleted file mode 100644
index 5e6614f..0000000
--- a/vendor/gif/Cargo.toml
+++ /dev/null
@@ -1,83 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "gif"
-version = "0.12.0"
-authors = ["The image-rs Developers"]
-exclude = [
- "tests/crashtest/*",
- "tests/samples/*",
- "benches/*.gif",
- "gif-afl/*",
-]
-description = "GIF de- and encoder"
-homepage = "https://github.com/image-rs/image-gif"
-documentation = "https://docs.rs/gif"
-readme = "README.md"
-license = "MIT/Apache-2.0"
-repository = "https://github.com/image-rs/image-gif"
-
-[[test]]
-name = "check_testimages"
-required-features = ["std"]
-
-[[test]]
-name = "crashtest"
-required-features = ["std"]
-
-[[test]]
-name = "decode"
-required-features = ["std"]
-
-[[test]]
-name = "stall"
-required-features = ["std"]
-
-[[test]]
-name = "roundtrip"
-required-features = ["std"]
-
-[[bench]]
-name = "decode"
-harness = false
-required-features = ["std"]
-
-[[bench]]
-name = "rgb_frame"
-harness = false
-required-features = ["std, color_quant"]
-
-[dependencies.color_quant]
-version = "1.0"
-optional = true
-
-[dependencies.weezl]
-version = "0.1.5"
-
-[dev-dependencies.criterion]
-version = "0.3.1"
-
-[dev-dependencies.glob]
-version = "0.3"
-
-[dev-dependencies.png]
-version = "0.17.2"
-
-[features]
-default = [
- "raii_no_panic",
- "std",
- "color_quant",
-]
-raii_no_panic = []
-std = []