aboutsummaryrefslogtreecommitdiff
path: root/vendor/image/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/image/Cargo.toml')
-rw-r--r--vendor/image/Cargo.toml188
1 files changed, 0 insertions, 188 deletions
diff --git a/vendor/image/Cargo.toml b/vendor/image/Cargo.toml
deleted file mode 100644
index 6864f9b..0000000
--- a/vendor/image/Cargo.toml
+++ /dev/null
@@ -1,188 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.61.0"
-name = "image"
-version = "0.24.7"
-authors = ["The image-rs Developers"]
-exclude = [
- "src/png/testdata/*",
- "examples/*",
- "tests/*",
-]
-description = "Imaging library. Provides basic image processing and encoders/decoders for common image formats."
-homepage = "https://github.com/image-rs/image"
-documentation = "https://docs.rs/image"
-readme = "README.md"
-categories = [
- "multimedia::images",
- "multimedia::encoding",
-]
-license = "MIT"
-repository = "https://github.com/image-rs/image"
-resolver = "2"
-
-[lib]
-name = "image"
-path = "./src/lib.rs"
-
-[[bench]]
-name = "decode"
-path = "benches/decode.rs"
-harness = false
-
-[[bench]]
-name = "encode"
-path = "benches/encode.rs"
-harness = false
-
-[[bench]]
-name = "copy_from"
-harness = false
-
-[dependencies.bytemuck]
-version = "1.7.0"
-features = ["extern_crate_alloc"]
-
-[dependencies.byteorder]
-version = "1.3.2"
-
-[dependencies.color_quant]
-version = "1.1"
-
-[dependencies.dav1d]
-version = "0.6.0"
-optional = true
-
-[dependencies.dcv-color-primitives]
-version = "0.4.0"
-optional = true
-
-[dependencies.exr]
-version = "1.5.0"
-optional = true
-
-[dependencies.gif]
-version = "0.12"
-optional = true
-
-[dependencies.jpeg]
-version = "0.3.0"
-optional = true
-default-features = false
-package = "jpeg-decoder"
-
-[dependencies.libwebp]
-version = "0.2.2"
-optional = true
-default-features = false
-package = "webp"
-
-[dependencies.mp4parse]
-version = "0.17.0"
-optional = true
-
-[dependencies.num-rational]
-version = "0.4"
-default-features = false
-
-[dependencies.num-traits]
-version = "0.2.0"
-
-[dependencies.png]
-version = "0.17.6"
-optional = true
-
-[dependencies.qoi]
-version = "0.4"
-optional = true
-
-[dependencies.ravif]
-version = "0.11.0"
-optional = true
-
-[dependencies.rgb]
-version = "0.8.25"
-optional = true
-
-[dependencies.tiff]
-version = "0.9.0"
-optional = true
-
-[dev-dependencies.crc32fast]
-version = "1.2.0"
-
-[dev-dependencies.criterion]
-version = "0.4"
-
-[dev-dependencies.glob]
-version = "0.3"
-
-[dev-dependencies.jpeg]
-version = "0.3.0"
-features = ["platform_independent"]
-default-features = false
-package = "jpeg-decoder"
-
-[dev-dependencies.num-complex]
-version = "0.4"
-
-[dev-dependencies.quickcheck]
-version = "1"
-
-[features]
-avif = ["avif-encoder"]
-avif-decoder = [
- "mp4parse",
- "dcv-color-primitives",
- "dav1d",
-]
-avif-encoder = [
- "ravif",
- "rgb",
-]
-benchmarks = []
-bmp = []
-dds = ["dxt"]
-default = [
- "gif",
- "jpeg",
- "ico",
- "png",
- "pnm",
- "tga",
- "tiff",
- "webp",
- "bmp",
- "hdr",
- "dxt",
- "dds",
- "farbfeld",
- "jpeg_rayon",
- "openexr",
- "qoi",
-]
-dxt = []
-farbfeld = []
-hdr = []
-ico = [
- "bmp",
- "png",
-]
-jpeg_rayon = ["jpeg/rayon"]
-openexr = ["exr"]
-pnm = []
-qoi = ["dep:qoi"]
-tga = []
-webp = []
-webp-encoder = ["libwebp"]