summaryrefslogtreecommitdiff
path: root/vendor/lebe/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/lebe/Cargo.toml')
-rw-r--r--vendor/lebe/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/vendor/lebe/Cargo.toml b/vendor/lebe/Cargo.toml
new file mode 100644
index 0000000..38a619e
--- /dev/null
+++ b/vendor/lebe/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "lebe"
+version = "0.5.2"
+authors = ["johannesvollmer <johannes596@t-online.de>"]
+description = "Tiny, dead simple, high performance endianness conversions with a generic API"
+documentation = "https://docs.rs/crate/lebe/"
+readme = "README.md"
+keywords = [
+ "endianness",
+ "binary",
+ "io",
+ "byteorder",
+ "endian",
+]
+categories = [
+ "encoding",
+ "filesystem",
+ "algorithms",
+]
+license = "BSD-3-Clause"
+repository = "https://github.com/johannesvollmer/lebe"
+
+[profile.bench]
+lto = true
+debug = true
+
+[lib]
+path = "src/lib.rs"
+test = true
+doctest = true
+bench = true
+doc = true
+plugin = false
+proc-macro = false
+
+[[bench]]
+name = "benches"
+harness = false
+
+[dev-dependencies.bencher]
+version = "0.1.5"
+
+[dev-dependencies.byteorder]
+version = "1.4.3"
+
+[features]
+
+[badges.maintenance]
+status = "actively-developed"