aboutsummaryrefslogtreecommitdiff
path: root/vendor/proc-macro2/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/proc-macro2/Cargo.toml')
-rw-r--r--vendor/proc-macro2/Cargo.toml67
1 files changed, 0 insertions, 67 deletions
diff --git a/vendor/proc-macro2/Cargo.toml b/vendor/proc-macro2/Cargo.toml
deleted file mode 100644
index 280bbdf..0000000
--- a/vendor/proc-macro2/Cargo.toml
+++ /dev/null
@@ -1,67 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.56"
-name = "proc-macro2"
-version = "1.0.76"
-authors = [
- "David Tolnay <dtolnay@gmail.com>",
- "Alex Crichton <alex@alexcrichton.com>",
-]
-autobenches = false
-description = "A substitute implementation of the compiler's `proc_macro` API to decouple token-based libraries from the procedural macro use case."
-documentation = "https://docs.rs/proc-macro2"
-readme = "README.md"
-keywords = [
- "macros",
- "syn",
-]
-categories = ["development-tools::procedural-macro-helpers"]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/dtolnay/proc-macro2"
-
-[package.metadata.docs.rs]
-rustc-args = [
- "--cfg",
- "procmacro2_semver_exempt",
-]
-rustdoc-args = [
- "--cfg",
- "procmacro2_semver_exempt",
- "--cfg",
- "doc_cfg",
- "--generate-link-to-definition",
-]
-targets = ["x86_64-unknown-linux-gnu"]
-
-[package.metadata.playground]
-features = ["span-locations"]
-
-[lib]
-doc-scrape-examples = false
-
-[dependencies.unicode-ident]
-version = "1.0"
-
-[dev-dependencies.quote]
-version = "1.0"
-default_features = false
-
-[dev-dependencies.rustversion]
-version = "1"
-
-[features]
-default = ["proc-macro"]
-nightly = []
-proc-macro = []
-span-locations = []