aboutsummaryrefslogtreecommitdiff
path: root/vendor/qoi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/qoi/Cargo.toml')
-rw-r--r--vendor/qoi/Cargo.toml66
1 files changed, 0 insertions, 66 deletions
diff --git a/vendor/qoi/Cargo.toml b/vendor/qoi/Cargo.toml
deleted file mode 100644
index 93c69d6..0000000
--- a/vendor/qoi/Cargo.toml
+++ /dev/null
@@ -1,66 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.61.0"
-name = "qoi"
-version = "0.4.1"
-authors = ["Ivan Smirnov <rust@ivan.smirnov.ie>"]
-exclude = ["assets/*"]
-description = "VERY fast encoder/decoder for QOI (Quite Okay Image) format"
-homepage = "https://github.com/aldanor/qoi-rust"
-documentation = "https://docs.rs/qoi"
-readme = "README.md"
-keywords = [
- "qoi",
- "graphics",
- "image",
- "encoding",
-]
-categories = [
- "multimedia::images",
- "multimedia::encoding",
-]
-license = "MIT/Apache-2.0"
-repository = "https://github.com/aldanor/qoi-rust"
-
-[profile.test]
-opt-level = 3
-
-[lib]
-name = "qoi"
-path = "src/lib.rs"
-doctest = false
-
-[dependencies.bytemuck]
-version = "1.12"
-
-[dev-dependencies.anyhow]
-version = "1.0"
-
-[dev-dependencies.cfg-if]
-version = "1.0"
-
-[dev-dependencies.png]
-version = "0.17"
-
-[dev-dependencies.rand]
-version = "0.8"
-
-[dev-dependencies.walkdir]
-version = "2.3"
-
-[features]
-alloc = []
-default = ["std"]
-reference = []
-std = []