aboutsummaryrefslogtreecommitdiff
path: root/vendor/scopeguard/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/scopeguard/Cargo.toml')
-rw-r--r--vendor/scopeguard/Cargo.toml43
1 files changed, 0 insertions, 43 deletions
diff --git a/vendor/scopeguard/Cargo.toml b/vendor/scopeguard/Cargo.toml
deleted file mode 100644
index acf5dce..0000000
--- a/vendor/scopeguard/Cargo.toml
+++ /dev/null
@@ -1,43 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-name = "scopeguard"
-version = "1.2.0"
-authors = ["bluss"]
-description = """
-A RAII scope guard that will run a given closure when it goes out of scope,
-even if the code between panics (assuming unwinding panic).
-
-Defines the macros `defer!`, `defer_on_unwind!`, `defer_on_success!` as
-shorthands for guards with one of the implemented strategies.
-"""
-documentation = "https://docs.rs/scopeguard/"
-readme = "README.md"
-keywords = [
- "scope-guard",
- "defer",
- "panic",
- "unwind",
-]
-categories = [
- "rust-patterns",
- "no-std",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/bluss/scopeguard"
-
-[package.metadata.release]
-no-dev-version = true
-
-[features]
-default = ["use_std"]
-use_std = []