aboutsummaryrefslogtreecommitdiff
path: root/vendor/simd-adler32/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/simd-adler32/Cargo.toml')
-rw-r--r--vendor/simd-adler32/Cargo.toml67
1 files changed, 0 insertions, 67 deletions
diff --git a/vendor/simd-adler32/Cargo.toml b/vendor/simd-adler32/Cargo.toml
deleted file mode 100644
index cdb8e0b..0000000
--- a/vendor/simd-adler32/Cargo.toml
+++ /dev/null
@@ -1,67 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "simd-adler32"
-version = "0.3.7"
-authors = ["Marvin Countryman <me@maar.vin>"]
-exclude = ["bench"]
-description = "A SIMD-accelerated Adler-32 hash algorithm implementation."
-readme = "README.md"
-keywords = [
- "simd",
- "avx2",
- "ssse3",
- "adler",
- "adler32",
-]
-categories = [
- "algorithms",
- "no-std",
-]
-license = "MIT"
-repository = "https://github.com/mcountryman/simd-adler32"
-
-[profile.release]
-opt-level = 2
-debug = 2
-
-[[bench]]
-name = "alts"
-path = "bench/alts.rs"
-harness = false
-
-[[bench]]
-name = "variants"
-path = "bench/variants.rs"
-harness = false
-
-[dev-dependencies.adler]
-version = "1.0.2"
-
-[dev-dependencies.adler32]
-version = "1.2.0"
-
-[dev-dependencies.criterion]
-version = "0.3"
-
-[dev-dependencies.rand]
-version = "0.8"
-
-[features]
-const-generics = []
-default = [
- "std",
- "const-generics",
-]
-nightly = []
-std = []