aboutsummaryrefslogtreecommitdiff
path: root/vendor/syn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/syn/Cargo.toml')
-rw-r--r--vendor/syn/Cargo.toml147
1 files changed, 0 insertions, 147 deletions
diff --git a/vendor/syn/Cargo.toml b/vendor/syn/Cargo.toml
deleted file mode 100644
index a467eb8..0000000
--- a/vendor/syn/Cargo.toml
+++ /dev/null
@@ -1,147 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.56"
-name = "syn"
-version = "2.0.48"
-authors = ["David Tolnay <dtolnay@gmail.com>"]
-include = [
- "/benches/**",
- "/Cargo.toml",
- "/LICENSE-APACHE",
- "/LICENSE-MIT",
- "/README.md",
- "/src/**",
- "/tests/**",
-]
-description = "Parser for Rust source code"
-documentation = "https://docs.rs/syn"
-readme = "README.md"
-keywords = [
- "macros",
- "syn",
-]
-categories = [
- "development-tools::procedural-macro-helpers",
- "parser-implementations",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/dtolnay/syn"
-
-[package.metadata.docs.rs]
-all-features = true
-rustdoc-args = [
- "--cfg",
- "doc_cfg",
- "--generate-link-to-definition",
-]
-targets = ["x86_64-unknown-linux-gnu"]
-
-[package.metadata.playground]
-features = [
- "full",
- "visit",
- "visit-mut",
- "fold",
- "extra-traits",
-]
-
-[lib]
-doc-scrape-examples = false
-
-[[bench]]
-name = "rust"
-harness = false
-required-features = [
- "full",
- "parsing",
-]
-
-[[bench]]
-name = "file"
-required-features = [
- "full",
- "parsing",
-]
-
-[dependencies.proc-macro2]
-version = "1.0.75"
-default-features = false
-
-[dependencies.quote]
-version = "1.0.35"
-optional = true
-default-features = false
-
-[dependencies.unicode-ident]
-version = "1"
-
-[dev-dependencies.anyhow]
-version = "1"
-
-[dev-dependencies.automod]
-version = "1"
-
-[dev-dependencies.flate2]
-version = "1"
-
-[dev-dependencies.insta]
-version = "1"
-
-[dev-dependencies.rayon]
-version = "1"
-
-[dev-dependencies.ref-cast]
-version = "1"
-
-[dev-dependencies.reqwest]
-version = "0.11"
-features = ["blocking"]
-
-[dev-dependencies.rustversion]
-version = "1"
-
-[dev-dependencies.syn-test-suite]
-version = "0"
-
-[dev-dependencies.tar]
-version = "0.4.16"
-
-[dev-dependencies.termcolor]
-version = "1"
-
-[dev-dependencies.walkdir]
-version = "2.3.2"
-
-[features]
-clone-impls = []
-default = [
- "derive",
- "parsing",
- "printing",
- "clone-impls",
- "proc-macro",
-]
-derive = []
-extra-traits = []
-fold = []
-full = []
-parsing = []
-printing = ["quote"]
-proc-macro = [
- "proc-macro2/proc-macro",
- "quote/proc-macro",
-]
-test = ["syn-test-suite/all-features"]
-visit = []
-visit-mut = []