summaryrefslogtreecommitdiff
path: root/vendor/zune-inflate/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/zune-inflate/Cargo.toml')
-rw-r--r--vendor/zune-inflate/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/zune-inflate/Cargo.toml b/vendor/zune-inflate/Cargo.toml
new file mode 100644
index 0000000..811126b
--- /dev/null
+++ b/vendor/zune-inflate/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "zune-inflate"
+version = "0.2.54"
+exclude = ["tests/"]
+description = "A heavily optimized deflate decompressor in Pure Rust"
+homepage = "https://github.com/etemesi254/zune-image/tree/main/zune-inflate"
+readme = "README.md"
+keywords = [
+ "compression",
+ "inflate",
+ "deflate",
+]
+categories = ["compression"]
+license = "MIT OR Apache-2.0 OR Zlib"
+
+[dependencies.simd-adler32]
+version = "0.3.4"
+optional = true
+default-features = false
+
+[features]
+default = [
+ "zlib",
+ "gzip",
+ "std",
+]
+gzip = []
+std = ["simd-adler32/std"]
+zlib = ["simd-adler32"]