aboutsummaryrefslogtreecommitdiff
path: root/vendor/addr2line/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/addr2line/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/addr2line/Cargo.toml')
-rw-r--r--vendor/addr2line/Cargo.toml147
1 files changed, 0 insertions, 147 deletions
diff --git a/vendor/addr2line/Cargo.toml b/vendor/addr2line/Cargo.toml
deleted file mode 100644
index b6b6b83..0000000
--- a/vendor/addr2line/Cargo.toml
+++ /dev/null
@@ -1,147 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.65"
-name = "addr2line"
-version = "0.21.0"
-exclude = [
- "/benches/*",
- "/fixtures/*",
- ".github",
-]
-description = "A cross-platform symbolication library written in Rust, using `gimli`"
-documentation = "https://docs.rs/addr2line"
-readme = "./README.md"
-keywords = [
- "DWARF",
- "debug",
- "elf",
- "symbolicate",
- "atos",
-]
-categories = ["development-tools::debugging"]
-license = "Apache-2.0 OR MIT"
-repository = "https://github.com/gimli-rs/addr2line"
-
-[profile.bench]
-codegen-units = 1
-debug = true
-
-[profile.release]
-debug = true
-
-[[example]]
-name = "addr2line"
-required-features = ["default"]
-
-[[test]]
-name = "output_equivalence"
-harness = false
-required-features = ["default"]
-
-[[test]]
-name = "correctness"
-required-features = ["default"]
-
-[[test]]
-name = "parse"
-required-features = ["std-object"]
-
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
-[dependencies.cpp_demangle]
-version = "0.4"
-features = ["alloc"]
-optional = true
-default-features = false
-
-[dependencies.fallible-iterator]
-version = "0.3.0"
-optional = true
-default-features = false
-
-[dependencies.gimli]
-version = "0.28.0"
-features = ["read"]
-default-features = false
-
-[dependencies.memmap2]
-version = "0.5.5"
-optional = true
-
-[dependencies.object]
-version = "0.32.0"
-features = ["read"]
-optional = true
-default-features = false
-
-[dependencies.rustc-demangle]
-version = "0.1"
-optional = true
-
-[dependencies.smallvec]
-version = "1"
-optional = true
-default-features = false
-
-[dev-dependencies.backtrace]
-version = "0.3.13"
-
-[dev-dependencies.clap]
-version = "4.3.21"
-features = ["wrap_help"]
-
-[dev-dependencies.findshlibs]
-version = "0.10"
-
-[dev-dependencies.libtest-mimic]
-version = "0.6.1"
-
-[dev-dependencies.typed-arena]
-version = "2"
-
-[features]
-default = [
- "rustc-demangle",
- "cpp_demangle",
- "std-object",
- "fallible-iterator",
- "smallvec",
- "memmap2",
-]
-rustc-dep-of-std = [
- "core",
- "alloc",
- "compiler_builtins",
- "gimli/rustc-dep-of-std",
-]
-std = ["gimli/std"]
-std-object = [
- "std",
- "object",
- "object/std",
- "object/compression",
- "gimli/endian-reader",
-]