aboutsummaryrefslogtreecommitdiff
path: root/vendor/bit_field/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/bit_field/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/bit_field/Cargo.toml')
-rw-r--r--vendor/bit_field/Cargo.toml36
1 files changed, 36 insertions, 0 deletions
diff --git a/vendor/bit_field/Cargo.toml b/vendor/bit_field/Cargo.toml
new file mode 100644
index 0000000..b52a63e
--- /dev/null
+++ b/vendor/bit_field/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "bit_field"
+version = "0.10.2"
+authors = ["Philipp Oppermann <dev@phil-opp.com>"]
+description = "Simple bit field trait providing get_bit, get_bits, set_bit, and set_bits methods for Rust's integral types."
+documentation = "https://docs.rs/bit_field"
+readme = "README.md"
+keywords = ["no_std"]
+license = "Apache-2.0/MIT"
+repository = "https://github.com/phil-opp/rust-bit-field"
+
+[package.metadata.release]
+dev-version = false
+pre-release-commit-message = "Release version {{version}}"
+
+[[package.metadata.release.pre-release-replacements]]
+file = "Changelog.md"
+search = "## Unreleased"
+replace = """
+## Unreleased
+
+# {{version}} – {{date}}"""
+exactly = 1
+
+[dependencies]