aboutsummaryrefslogtreecommitdiff
path: root/vendor/bytemuck/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/bytemuck/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/bytemuck/Cargo.toml')
-rw-r--r--vendor/bytemuck/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/vendor/bytemuck/Cargo.toml b/vendor/bytemuck/Cargo.toml
new file mode 100644
index 0000000..9bd2e5d
--- /dev/null
+++ b/vendor/bytemuck/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "bytemuck"
+version = "1.14.0"
+authors = ["Lokathor <zefria@gmail.com>"]
+exclude = ["/pedantic.bat"]
+description = "A crate for mucking around with piles of bytes."
+readme = "README.md"
+keywords = [
+ "transmute",
+ "bytes",
+ "casting",
+]
+categories = [
+ "encoding",
+ "no-std",
+]
+license = "Zlib OR Apache-2.0 OR MIT"
+repository = "https://github.com/Lokathor/bytemuck"
+
+[package.metadata.docs.rs]
+features = [
+ "nightly_docs",
+ "derive",
+ "extern_crate_alloc",
+ "extern_crate_std",
+ "zeroable_maybe_uninit",
+ "zeroable_atomics",
+ "min_const_generics",
+ "wasm_simd",
+ "must_cast",
+]
+
+[package.metadata.playground]
+features = [
+ "derive",
+ "extern_crate_alloc",
+ "extern_crate_std",
+ "zeroable_maybe_uninit",
+ "zeroable_atomics",
+ "min_const_generics",
+ "wasm_simd",
+ "must_cast",
+]
+
+[dependencies.bytemuck_derive]
+version = "1.4"
+optional = true
+
+[features]
+aarch64_simd = []
+align_offset = []
+derive = ["bytemuck_derive"]
+extern_crate_alloc = []
+extern_crate_std = ["extern_crate_alloc"]
+min_const_generics = []
+must_cast = []
+nightly_docs = []
+nightly_portable_simd = []
+nightly_stdsimd = []
+unsound_ptr_pod_impl = []
+wasm_simd = []
+zeroable_atomics = []
+zeroable_maybe_uninit = []