aboutsummaryrefslogtreecommitdiff
path: root/vendor/clap_derive/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/clap_derive/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/clap_derive/Cargo.toml')
-rw-r--r--vendor/clap_derive/Cargo.toml72
1 files changed, 0 insertions, 72 deletions
diff --git a/vendor/clap_derive/Cargo.toml b/vendor/clap_derive/Cargo.toml
deleted file mode 100644
index 67663ee..0000000
--- a/vendor/clap_derive/Cargo.toml
+++ /dev/null
@@ -1,72 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.70.0"
-name = "clap_derive"
-version = "4.4.7"
-include = [
- "build.rs",
- "src/**/*",
- "Cargo.toml",
- "LICENSE*",
- "README.md",
- "benches/**/*",
- "examples/**/*",
-]
-description = "Parse command line argument by defining a struct, derive crate."
-readme = "README.md"
-keywords = [
- "clap",
- "cli",
- "parse",
- "derive",
- "proc_macro",
-]
-categories = [
- "command-line-interface",
- "development-tools::procedural-macro-helpers",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/clap-rs/clap/tree/master/clap_derive"
-
-[package.metadata.docs.rs]
-targets = ["x86_64-unknown-linux-gnu"]
-
-[package.metadata.release]
-dependent-version = "upgrade"
-shared-version = true
-tag-name = "v{{version}}"
-
-[lib]
-bench = false
-proc-macro = true
-
-[dependencies.heck]
-version = "0.4.0"
-
-[dependencies.proc-macro2]
-version = "1.0.42"
-
-[dependencies.quote]
-version = "1.0.9"
-
-[dependencies.syn]
-version = "2.0.8"
-features = ["full"]
-
-[features]
-debug = []
-default = []
-deprecated = []
-raw-deprecated = ["deprecated"]
-unstable-v5 = ["deprecated"]