aboutsummaryrefslogtreecommitdiff
path: root/vendor/gimli/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/gimli/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/gimli/Cargo.toml')
-rw-r--r--vendor/gimli/Cargo.toml109
1 files changed, 0 insertions, 109 deletions
diff --git a/vendor/gimli/Cargo.toml b/vendor/gimli/Cargo.toml
deleted file mode 100644
index 4abd009..0000000
--- a/vendor/gimli/Cargo.toml
+++ /dev/null
@@ -1,109 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.60"
-name = "gimli"
-version = "0.28.1"
-include = [
- "/CHANGELOG.md",
- "/Cargo.toml",
- "/LICENSE-APACHE",
- "/LICENSE-MIT",
- "/README.md",
- "/src",
-]
-description = "A library for reading and writing the DWARF debugging format."
-documentation = "https://docs.rs/gimli"
-readme = "./README.md"
-keywords = [
- "DWARF",
- "debug",
- "ELF",
- "eh_frame",
-]
-categories = [
- "development-tools::debugging",
- "development-tools::profiling",
- "parser-implementations",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/gimli-rs/gimli"
-resolver = "2"
-
-[profile.bench]
-codegen-units = 1
-debug = 2
-split-debuginfo = "packed"
-
-[profile.test]
-split-debuginfo = "packed"
-
-[dependencies.alloc]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-alloc"
-
-[dependencies.compiler_builtins]
-version = "0.1.2"
-optional = true
-
-[dependencies.core]
-version = "1.0.0"
-optional = true
-package = "rustc-std-workspace-core"
-
-[dependencies.fallible-iterator]
-version = "0.3.0"
-optional = true
-default-features = false
-
-[dependencies.indexmap]
-version = "2.0.0"
-optional = true
-
-[dependencies.stable_deref_trait]
-version = "1.1.0"
-optional = true
-default-features = false
-
-[dev-dependencies.test-assembler]
-version = "0.1.3"
-
-[features]
-default = [
- "read-all",
- "write",
-]
-endian-reader = [
- "read",
- "dep:stable_deref_trait",
-]
-fallible-iterator = ["dep:fallible-iterator"]
-read = ["read-core"]
-read-all = [
- "read",
- "std",
- "fallible-iterator",
- "endian-reader",
-]
-read-core = []
-rustc-dep-of-std = [
- "dep:core",
- "dep:alloc",
- "dep:compiler_builtins",
-]
-std = [
- "fallible-iterator?/std",
- "stable_deref_trait?/std",
-]
-write = ["dep:indexmap"]