aboutsummaryrefslogtreecommitdiff
path: root/vendor/jpeg-decoder/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
committerValentin Popov <valentin@popov.link>2024-01-08 00:21:28 +0300
commit1b6a04ca5504955c571d1c97504fb45ea0befee4 (patch)
tree7579f518b23313e8a9748a88ab6173d5e030b227 /vendor/jpeg-decoder/Cargo.toml
parent5ecd8cf2cba827454317368b68571df0d13d7842 (diff)
downloadfparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.tar.xz
fparkan-1b6a04ca5504955c571d1c97504fb45ea0befee4.zip
Initial vendor packages
Signed-off-by: Valentin Popov <valentin@popov.link>
Diffstat (limited to 'vendor/jpeg-decoder/Cargo.toml')
-rw-r--r--vendor/jpeg-decoder/Cargo.toml81
1 files changed, 81 insertions, 0 deletions
diff --git a/vendor/jpeg-decoder/Cargo.toml b/vendor/jpeg-decoder/Cargo.toml
new file mode 100644
index 0000000..1fe5965
--- /dev/null
+++ b/vendor/jpeg-decoder/Cargo.toml
@@ -0,0 +1,81 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.61.0"
+name = "jpeg-decoder"
+version = "0.3.0"
+authors = ["The image-rs Developers"]
+exclude = [
+ "/tests/*",
+ "!/tests/*.rs",
+]
+description = "JPEG decoder"
+documentation = "https://docs.rs/jpeg-decoder"
+readme = "README.md"
+keywords = [
+ "jpeg",
+ "jpg",
+ "decoder",
+ "image",
+]
+license = "MIT / Apache-2.0"
+repository = "https://github.com/image-rs/jpeg-decoder"
+resolver = "2"
+
+[[test]]
+name = "rayon"
+required-features = ["rayon"]
+
+[[test]]
+name = "rayon-0"
+required-features = ["rayon"]
+
+[[test]]
+name = "rayon-1"
+required-features = ["rayon"]
+
+[[test]]
+name = "rayon-2"
+required-features = ["rayon"]
+
+[[bench]]
+name = "decoding_benchmark"
+harness = false
+
+[[bench]]
+name = "large_image"
+harness = false
+
+[dependencies.rayon]
+version = "1.5.1"
+optional = true
+
+[dev-dependencies.criterion]
+version = "0.3"
+
+[dev-dependencies.png]
+version = "0.16"
+
+[dev-dependencies.walkdir]
+version = "2.0"
+
+[dev-dependencies.wasm-bindgen]
+version = "=0.2.83"
+
+[dev-dependencies.wasm-bindgen-test]
+version = "0.3"
+
+[features]
+default = ["rayon"]
+nightly_aarch64_neon = []
+platform_independent = []