aboutsummaryrefslogtreecommitdiff
path: root/vendor/lock_api/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/lock_api/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/lock_api/Cargo.toml')
-rw-r--r--vendor/lock_api/Cargo.toml60
1 files changed, 0 insertions, 60 deletions
diff --git a/vendor/lock_api/Cargo.toml b/vendor/lock_api/Cargo.toml
deleted file mode 100644
index 501db6e..0000000
--- a/vendor/lock_api/Cargo.toml
+++ /dev/null
@@ -1,60 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.49.0"
-name = "lock_api"
-version = "0.4.11"
-authors = ["Amanieu d'Antras <amanieu@gmail.com>"]
-description = "Wrappers to create fully-featured Mutex and RwLock types. Compatible with no_std."
-keywords = [
- "mutex",
- "rwlock",
- "lock",
- "no_std",
-]
-categories = [
- "concurrency",
- "no-std",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/Amanieu/parking_lot"
-
-[package.metadata.docs.rs]
-all-features = true
-rustdoc-args = [
- "--cfg",
- "docsrs",
- "--generate-link-to-definition",
-]
-
-[dependencies.owning_ref]
-version = "0.4.1"
-optional = true
-
-[dependencies.scopeguard]
-version = "1.1.0"
-default-features = false
-
-[dependencies.serde]
-version = "1.0.126"
-optional = true
-default-features = false
-
-[build-dependencies.autocfg]
-version = "1.1.0"
-
-[features]
-arc_lock = []
-atomic_usize = []
-default = ["atomic_usize"]
-nightly = []