aboutsummaryrefslogtreecommitdiff
path: root/vendor/textwrap/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/textwrap/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/textwrap/Cargo.toml')
-rw-r--r--vendor/textwrap/Cargo.toml106
1 files changed, 0 insertions, 106 deletions
diff --git a/vendor/textwrap/Cargo.toml b/vendor/textwrap/Cargo.toml
deleted file mode 100644
index 3191af7..0000000
--- a/vendor/textwrap/Cargo.toml
+++ /dev/null
@@ -1,106 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "textwrap"
-version = "0.15.2"
-authors = ["Martin Geisler <martin@geisler.net>"]
-exclude = [
- ".github/",
- ".gitignore",
- "benches/",
- "examples/",
- "fuzz/",
- "images/",
-]
-description = "Powerful library for word wrapping, indenting, and dedenting strings"
-documentation = "https://docs.rs/textwrap/"
-readme = "README.md"
-keywords = [
- "text",
- "formatting",
- "wrap",
- "typesetting",
- "hyphenation",
-]
-categories = [
- "text-processing",
- "command-line-interface",
-]
-license = "MIT"
-repository = "https://github.com/mgeisler/textwrap"
-
-[package.metadata.docs.rs]
-all-features = true
-
-[[example]]
-name = "hyphenation"
-path = "examples/hyphenation.rs"
-required-features = ["hyphenation"]
-
-[[example]]
-name = "termwidth"
-path = "examples/termwidth.rs"
-required-features = ["terminal_size"]
-
-[[bench]]
-name = "linear"
-path = "benches/linear.rs"
-harness = false
-
-[[bench]]
-name = "indent"
-path = "benches/indent.rs"
-harness = false
-
-[dependencies.hyphenation]
-version = "0.8.4"
-features = ["embed_en-us"]
-optional = true
-
-[dependencies.smawk]
-version = "0.3.1"
-optional = true
-
-[dependencies.terminal_size]
-version = "0.1.17"
-optional = true
-
-[dependencies.unicode-linebreak]
-version = "0.1.2"
-optional = true
-
-[dependencies.unicode-width]
-version = "0.1.9"
-optional = true
-
-[dev-dependencies.criterion]
-version = "0.3.5"
-
-[dev-dependencies.lipsum]
-version = "0.8.0"
-
-[dev-dependencies.unic-emoji-char]
-version = "0.9.0"
-
-[dev-dependencies.version-sync]
-version = "0.9.4"
-
-[features]
-default = [
- "unicode-linebreak",
- "unicode-width",
- "smawk",
-]
-
-[target."cfg(unix)".dev-dependencies.termion]
-version = "1.5.6"