aboutsummaryrefslogtreecommitdiff
path: root/vendor/zeroize/Cargo.toml
diff options
context:
space:
mode:
authorValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
committerValentin Popov <valentin@popov.link>2024-07-19 15:37:58 +0300
commita990de90fe41456a23e58bd087d2f107d321f3a1 (patch)
tree15afc392522a9e85dc3332235e311b7d39352ea9 /vendor/zeroize/Cargo.toml
parent3d48cd3f81164bbfc1a755dc1d4a9a02f98c8ddd (diff)
downloadfparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.tar.xz
fparkan-a990de90fe41456a23e58bd087d2f107d321f3a1.zip
Deleted vendor folder
Diffstat (limited to 'vendor/zeroize/Cargo.toml')
-rw-r--r--vendor/zeroize/Cargo.toml63
1 files changed, 0 insertions, 63 deletions
diff --git a/vendor/zeroize/Cargo.toml b/vendor/zeroize/Cargo.toml
deleted file mode 100644
index 1cf0f0a..0000000
--- a/vendor/zeroize/Cargo.toml
+++ /dev/null
@@ -1,63 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.60"
-name = "zeroize"
-version = "1.7.0"
-authors = ["The RustCrypto Project Developers"]
-description = """
-Securely clear secrets from memory with a simple trait built on
-stable Rust primitives which guarantee memory is zeroed using an
-operation will not be 'optimized away' by the compiler.
-Uses a portable pure Rust implementation that works everywhere,
-even WASM!
-"""
-readme = "README.md"
-keywords = [
- "memory",
- "memset",
- "secure",
- "volatile",
- "zero",
-]
-categories = [
- "cryptography",
- "memory-management",
- "no-std",
- "os",
-]
-license = "Apache-2.0 OR MIT"
-repository = "https://github.com/RustCrypto/utils/tree/master/zeroize"
-
-[package.metadata.docs.rs]
-all-features = true
-rustdoc-args = [
- "--cfg",
- "docsrs",
-]
-
-[dependencies.serde]
-version = "1.0"
-optional = true
-default-features = false
-
-[dependencies.zeroize_derive]
-version = "1.3"
-optional = true
-
-[features]
-aarch64 = []
-alloc = []
-default = ["alloc"]
-derive = ["zeroize_derive"]
-std = ["alloc"]