aboutsummaryrefslogtreecommitdiff
path: root/vendor/anstream/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/anstream/Cargo.toml')
-rw-r--r--vendor/anstream/Cargo.toml144
1 files changed, 144 insertions, 0 deletions
diff --git a/vendor/anstream/Cargo.toml b/vendor/anstream/Cargo.toml
new file mode 100644
index 0000000..a64ec8d
--- /dev/null
+++ b/vendor/anstream/Cargo.toml
@@ -0,0 +1,144 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70.0"
+name = "anstream"
+version = "0.6.5"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "Cargo.lock",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "A simple cross platform library for writing colored text to a terminal."
+homepage = "https://github.com/rust-cli/anstyle"
+readme = "README.md"
+keywords = [
+ "ansi",
+ "terminal",
+ "color",
+ "strip",
+ "wincon",
+]
+categories = ["command-line-interface"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-cli/anstyle.git"
+
+[package.metadata.docs.rs]
+cargo-args = [
+ "-Zunstable-options",
+ "-Zrustdoc-scrape-examples",
+]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{version}}"
+search = "Unreleased"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = "...{{tag_name}}"
+search = '\.\.\.HEAD'
+
+[[package.metadata.release.pre-release-replacements]]
+file = "CHANGELOG.md"
+min = 1
+replace = "{{date}}"
+search = "ReleaseDate"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-header -->
+## [Unreleased] - ReleaseDate
+"""
+search = "<!-- next-header -->"
+
+[[package.metadata.release.pre-release-replacements]]
+exactly = 1
+file = "CHANGELOG.md"
+replace = """
+<!-- next-url -->
+[Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
+search = "<!-- next-url -->"
+
+[[bench]]
+name = "strip"
+harness = false
+
+[[bench]]
+name = "wincon"
+harness = false
+
+[[bench]]
+name = "stream"
+harness = false
+
+[dependencies.anstyle]
+version = "1.0.0"
+
+[dependencies.anstyle-parse]
+version = "0.2.0"
+
+[dependencies.anstyle-query]
+version = "1.0.0"
+optional = true
+
+[dependencies.colorchoice]
+version = "1.0.0"
+optional = true
+
+[dependencies.utf8parse]
+version = "0.2.1"
+
+[dev-dependencies.criterion]
+version = "0.5.1"
+
+[dev-dependencies.lexopt]
+version = "0.3.0"
+
+[dev-dependencies.owo-colors]
+version = "3.5.0"
+
+[dev-dependencies.proptest]
+version = "1.4.0"
+
+[dev-dependencies.strip-ansi-escapes]
+version = "0.2.0"
+
+[features]
+auto = [
+ "dep:anstyle-query",
+ "dep:colorchoice",
+]
+default = [
+ "auto",
+ "wincon",
+]
+test = []
+wincon = ["dep:anstyle-wincon"]
+
+[target."cfg(windows)".dependencies.anstyle-wincon]
+version = "3.0.1"
+optional = true