aboutsummaryrefslogtreecommitdiff
path: root/vendor/anstyle-wincon/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/anstyle-wincon/Cargo.toml')
-rw-r--r--vendor/anstyle-wincon/Cargo.toml94
1 files changed, 0 insertions, 94 deletions
diff --git a/vendor/anstyle-wincon/Cargo.toml b/vendor/anstyle-wincon/Cargo.toml
deleted file mode 100644
index 137188d..0000000
--- a/vendor/anstyle-wincon/Cargo.toml
+++ /dev/null
@@ -1,94 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.70.0"
-name = "anstyle-wincon"
-version = "3.0.2"
-include = [
- "build.rs",
- "src/**/*",
- "Cargo.toml",
- "Cargo.lock",
- "LICENSE*",
- "README.md",
- "benches/**/*",
- "examples/**/*",
-]
-description = "Styling legacy Windows terminals"
-homepage = "https://github.com/rust-cli/anstyle"
-readme = "README.md"
-keywords = [
- "ansi",
- "terminal",
- "color",
- "windows",
-]
-categories = ["command-line-interface"]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/rust-cli/anstyle.git"
-
-[package.metadata.docs.rs]
-features = []
-rustdoc-args = [
- "--cfg",
- "docsrs",
-]
-targets = ["x86_64-pc-windows-msvc"]
-
-[[package.metadata.release.pre-release-replacements]]
-file = "CHANGELOG.md"
-min = 1
-replace = "{{version}}"
-search = "Unreleased"
-
-[[package.metadata.release.pre-release-replacements]]
-exactly = 1
-file = "CHANGELOG.md"
-replace = "...{{tag_name}}"
-search = '\.\.\.HEAD'
-
-[[package.metadata.release.pre-release-replacements]]
-file = "CHANGELOG.md"
-min = 1
-replace = "{{date}}"
-search = "ReleaseDate"
-
-[[package.metadata.release.pre-release-replacements]]
-exactly = 1
-file = "CHANGELOG.md"
-replace = """
-<!-- next-header -->
-## [Unreleased] - ReleaseDate
-"""
-search = "<!-- next-header -->"
-
-[[package.metadata.release.pre-release-replacements]]
-exactly = 1
-file = "CHANGELOG.md"
-replace = """
-<!-- next-url -->
-[Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
-search = "<!-- next-url -->"
-
-[dependencies.anstyle]
-version = "1.0.0"
-
-[dev-dependencies.lexopt]
-version = "0.3.0"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52.0"
-features = [
- "Win32_System_Console",
- "Win32_Foundation",
-]