aboutsummaryrefslogtreecommitdiff
path: root/vendor/clap_derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/clap_derive/Cargo.toml')
-rw-r--r--vendor/clap_derive/Cargo.toml72
1 files changed, 72 insertions, 0 deletions
diff --git a/vendor/clap_derive/Cargo.toml b/vendor/clap_derive/Cargo.toml
new file mode 100644
index 0000000..67663ee
--- /dev/null
+++ b/vendor/clap_derive/Cargo.toml
@@ -0,0 +1,72 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70.0"
+name = "clap_derive"
+version = "4.4.7"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "Parse command line argument by defining a struct, derive crate."
+readme = "README.md"
+keywords = [
+ "clap",
+ "cli",
+ "parse",
+ "derive",
+ "proc_macro",
+]
+categories = [
+ "command-line-interface",
+ "development-tools::procedural-macro-helpers",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/clap-rs/clap/tree/master/clap_derive"
+
+[package.metadata.docs.rs]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[package.metadata.release]
+dependent-version = "upgrade"
+shared-version = true
+tag-name = "v{{version}}"
+
+[lib]
+bench = false
+proc-macro = true
+
+[dependencies.heck]
+version = "0.4.0"
+
+[dependencies.proc-macro2]
+version = "1.0.42"
+
+[dependencies.quote]
+version = "1.0.9"
+
+[dependencies.syn]
+version = "2.0.8"
+features = ["full"]
+
+[features]
+debug = []
+default = []
+deprecated = []
+raw-deprecated = ["deprecated"]
+unstable-v5 = ["deprecated"]