aboutsummaryrefslogtreecommitdiff
path: root/vendor/crossbeam-epoch/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/crossbeam-epoch/Cargo.toml')
-rw-r--r--vendor/crossbeam-epoch/Cargo.toml63
1 files changed, 0 insertions, 63 deletions
diff --git a/vendor/crossbeam-epoch/Cargo.toml b/vendor/crossbeam-epoch/Cargo.toml
deleted file mode 100644
index 87d30e7..0000000
--- a/vendor/crossbeam-epoch/Cargo.toml
+++ /dev/null
@@ -1,63 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2021"
-rust-version = "1.61"
-name = "crossbeam-epoch"
-version = "0.9.17"
-description = "Epoch-based garbage collection"
-homepage = "https://github.com/crossbeam-rs/crossbeam/tree/master/crossbeam-epoch"
-readme = "README.md"
-keywords = [
- "lock-free",
- "rcu",
- "atomic",
- "garbage",
-]
-categories = [
- "concurrency",
- "memory-management",
- "no-std",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/crossbeam-rs/crossbeam"
-
-[dependencies.cfg-if]
-version = "1"
-
-[dependencies.crossbeam-utils]
-version = "0.8.18"
-default-features = false
-
-[dev-dependencies.rand]
-version = "0.8"
-
-[build-dependencies.autocfg]
-version = "1"
-
-[features]
-alloc = []
-default = ["std"]
-loom = [
- "loom-crate",
- "crossbeam-utils/loom",
-]
-nightly = ["crossbeam-utils/nightly"]
-std = [
- "alloc",
- "crossbeam-utils/std",
-]
-
-[target."cfg(crossbeam_loom)".dependencies.loom-crate]
-version = "0.7.1"
-optional = true
-package = "loom"