aboutsummaryrefslogtreecommitdiff
path: root/vendor/is-terminal/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/is-terminal/Cargo.toml')
-rw-r--r--vendor/is-terminal/Cargo.toml67
1 files changed, 0 insertions, 67 deletions
diff --git a/vendor/is-terminal/Cargo.toml b/vendor/is-terminal/Cargo.toml
deleted file mode 100644
index a1168f2..0000000
--- a/vendor/is-terminal/Cargo.toml
+++ /dev/null
@@ -1,67 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-rust-version = "1.63"
-name = "is-terminal"
-version = "0.4.10"
-authors = [
- "softprops <d.tangren@gmail.com>",
- "Dan Gohman <dev@sunfishcode.online>",
-]
-include = [
- "src",
- "build.rs",
- "Cargo.toml",
- "COPYRIGHT",
- "LICENSE*",
- "/*.md",
-]
-description = "Test whether a given stream is a terminal"
-documentation = "https://docs.rs/is-terminal"
-readme = "README.md"
-keywords = [
- "terminal",
- "tty",
- "isatty",
-]
-categories = ["command-line-interface"]
-license = "MIT"
-repository = "https://github.com/sunfishcode/is-terminal"
-
-[dev-dependencies.atty]
-version = "0.2.14"
-
-[target."cfg(any(unix, target_os = \"wasi\"))".dev-dependencies.libc]
-version = "0.2.110"
-
-[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dependencies.rustix]
-version = "0.38.0"
-features = ["termios"]
-
-[target."cfg(not(any(windows, target_os = \"hermit\", target_os = \"unknown\")))".dev-dependencies.rustix]
-version = "0.38.0"
-features = ["stdio"]
-
-[target."cfg(target_os = \"hermit\")".dependencies.hermit-abi]
-version = "0.3.0"
-
-[target."cfg(windows)".dependencies.windows-sys]
-version = "0.52.0"
-features = [
- "Win32_Foundation",
- "Win32_Storage_FileSystem",
- "Win32_System_Console",
-]
-
-[target."cfg(windows)".dev-dependencies.tempfile]
-version = "3"