aboutsummaryrefslogtreecommitdiff
path: root/vendor/png/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/png/Cargo.toml')
-rw-r--r--vendor/png/Cargo.toml80
1 files changed, 80 insertions, 0 deletions
diff --git a/vendor/png/Cargo.toml b/vendor/png/Cargo.toml
new file mode 100644
index 0000000..00756a4
--- /dev/null
+++ b/vendor/png/Cargo.toml
@@ -0,0 +1,80 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.57"
+name = "png"
+version = "0.17.10"
+authors = ["The image-rs Developers"]
+include = [
+ "/LICENSE-MIT",
+ "/LICENSE-APACHE",
+ "/README.md",
+ "/CHANGES.md",
+ "/src/",
+ "/examples/",
+ "/benches/",
+]
+description = "PNG decoding and encoding library in pure Rust"
+readme = "README.md"
+categories = ["multimedia::images"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/image-rs/image-png.git"
+
+[[bench]]
+name = "decoder"
+path = "benches/decoder.rs"
+harness = false
+
+[dependencies.bitflags]
+version = "1.0"
+
+[dependencies.crc32fast]
+version = "1.2.0"
+
+[dependencies.fdeflate]
+version = "0.3.0"
+
+[dependencies.flate2]
+version = "1.0"
+
+[dependencies.miniz_oxide]
+version = "0.7.1"
+features = ["simd"]
+
+[dev-dependencies.clap]
+version = "3.0"
+features = ["derive"]
+
+[dev-dependencies.criterion]
+version = "0.3.1"
+
+[dev-dependencies.getopts]
+version = "0.2.14"
+
+[dev-dependencies.glium]
+version = "0.32"
+features = ["glutin"]
+default-features = false
+
+[dev-dependencies.glob]
+version = "0.3"
+
+[dev-dependencies.rand]
+version = "0.8.4"
+
+[dev-dependencies.term]
+version = "0.7"
+
+[features]
+benchmarks = []
+unstable = []