aboutsummaryrefslogtreecommitdiff
path: root/vendor/rand_core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rand_core/Cargo.toml')
-rw-r--r--vendor/rand_core/Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/vendor/rand_core/Cargo.toml b/vendor/rand_core/Cargo.toml
new file mode 100644
index 0000000..01d8ced
--- /dev/null
+++ b/vendor/rand_core/Cargo.toml
@@ -0,0 +1,41 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "rand_core"
+version = "0.4.2"
+authors = ["The Rand Project Developers", "The Rust Project Developers"]
+description = "Core random number generator traits and tools for implementation.\n"
+homepage = "https://crates.io/crates/rand_core"
+documentation = "https://rust-random.github.io/rand/rand_core/"
+readme = "README.md"
+keywords = ["random", "rng"]
+categories = ["algorithms", "no-std"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/rust-random/rand"
+[dependencies.serde]
+version = "1"
+optional = true
+
+[dependencies.serde_derive]
+version = "^1.0.38"
+optional = true
+
+[features]
+alloc = []
+serde1 = ["serde", "serde_derive"]
+std = ["alloc"]
+[badges.appveyor]
+repository = "rust-random/rand"
+
+[badges.travis-ci]
+repository = "rust-random/rand"