aboutsummaryrefslogtreecommitdiff
path: root/vendor/weezl/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/weezl/Cargo.toml')
-rw-r--r--vendor/weezl/Cargo.toml101
1 files changed, 101 insertions, 0 deletions
diff --git a/vendor/weezl/Cargo.toml b/vendor/weezl/Cargo.toml
new file mode 100644
index 0000000..990ba95
--- /dev/null
+++ b/vendor/weezl/Cargo.toml
@@ -0,0 +1,101 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "weezl"
+version = "0.1.7"
+authors = ["HeroicKatora <andreas.molzer@gmx.de>"]
+exclude = ["benches/*.lzw"]
+description = "Fast LZW compression and decompression."
+documentation = "https://docs.rs/weezl"
+readme = "README.md"
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/image-rs/lzw.git"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[lib]
+name = "weezl"
+bench = false
+
+[[bin]]
+name = "lzw"
+path = "bin/lzw.rs"
+bench = false
+required-features = ["std"]
+
+[[example]]
+name = "lzw-compress"
+required-features = ["std"]
+
+[[example]]
+name = "lzw-decompress"
+required-features = ["std"]
+
+[[test]]
+name = "async"
+required-features = [
+ "async",
+ "std",
+]
+
+[[test]]
+name = "roundtrip"
+required-features = ["std"]
+
+[[test]]
+name = "roundtrip_vec"
+required-features = ["alloc"]
+
+[[test]]
+name = "implicit_reset"
+required-features = ["std"]
+
+[[bench]]
+name = "msb8"
+harness = false
+required-features = ["std"]
+
+[dependencies.futures]
+version = "0.3.12"
+features = ["std"]
+optional = true
+default-features = false
+
+[dev-dependencies.criterion]
+version = "0.3.1"
+
+[dev-dependencies.tokio]
+version = "1"
+features = [
+ "macros",
+ "io-util",
+ "net",
+ "rt",
+ "rt-multi-thread",
+]
+default-features = false
+
+[dev-dependencies.tokio-util]
+version = "0.6.2"
+features = ["compat"]
+default-features = false
+
+[features]
+alloc = []
+async = [
+ "futures",
+ "std",
+]
+default = ["std"]
+std = ["alloc"]